
Installation Guide

Abila MIP



This is a publication of Abila, Inc.

Version 2016.2

© 2016 Abila, Inc. and its affiliated entities. All rights reserved.

Abila, the Abila logos, and the Abila product and service names mentioned herein are registered
trademarks or trademarks of Abila, Inc. or its affiliated entities. All other trademarks are the property of
their respective owners.



Contents

Chapter 1: Getting Started 1

SystemRequirements 2

Before You Begin 2

Chapter 2: New User - Server Install 6

Server Install Overview 6

Local Server Configuration 7

Directory StructureOverview 8

Data Files and Directory Structure 8

MIP Share Directory 9

SQL Server (Express Download) 10

SQL Server Express (Can be downloaded by following a link) 10

AbilaMIP Server Install 11

Granting Access to theMIP Share Directory 16

Chapter 3: New User - Workstation Install 18

Ensuring Access to “All Users” Folder 18

Data Files and Directory Structure 18

MIP Directory 19

AbilaMIP Workstation Install 19

Chapter 4: Existing User - Upgrading 24

Upgrading from a Previous Version 24

Changing Your Database Engine 25

Updating Your Organization Database to Version 2016.2 25

Activating Your License 26

Abila MIP
Installation Guide

iii



Contents

Adding aModule to an Organization 26

Setting Up Security 27

Chapter 5: Existing User - Server Install 28

Server Install Overview 28

Directory StructureOverview 29

Data Files and Directory Structure 29

MIP Share Directory 29

SQL Server Install 30

SQL Server (Express Downloaded) 31

AbilaMIP Server Install 32

Chapter 6: Existing User - Workstation Install 37

Ensuring Access to “All Users” Folder 37

Data Files and Directory Structure 38

MIP Directory 38

AbilaMIP Workstation Install 38

Chapter 7: Alerts IIS Install 45

Download AbilaMIP 45

Begin Installation Process 45

AbilaMIP Alerts Server Install 47

Setting Up Alerts 50

Chapter 8: Uninstalling Abila MIP 53

Uninstalling Steps 53

Chapter 9: Help Documentation 55

Abila MIP
Installation Guide

iv



Contents

Accessing Documentation 55

Chapter 10: Supplemental Maintenance 56

Backing Up Organization Database 56

Restoring Organization Database 56

Compressing Organization Database 57

AbilaMIP
Installation Guide

v



Chapter 1: Getting Started

This guide includes combined instructions for both New and Upgrade installations of AbilaMIP.

New Installation Scenarios

You are installing a one-user version of MIP (programs and database) on a single computer. The
computermay ormay not be part of a network, but the programs and database reside on the local
hard drive of this computer. In this scenario, there are no network files involved, and no other
computers have access to the system/database. Optional, IIS Web Server running on the single
computer* or separately if connected to your network.

You have a network comprised of a servermachinewith one ormore local computers attached, and
you want to install the database on the servermachine so that other users can access it from their
local computers (either one at a time or simultaneously depending on your license). Optional,
IIS Web Server running on separate server on your network.

You have a network comprised of two ormore local computers that can access each other's shared
drives, and you want to install the database on one computer's shared drive so that other users can
access it from their local computers (either one at a time or simultaneously depending on your
license). Optional, IIS Web Server running on separate server on your network.

You have a network and want to install the database on a servermachine for backup and security
purposes, even though only one user accesses it from a single local computer. Optional, IIS Web
Server running on separate server on your network.

You are installing theMIP programs and database in a virtual environment. Youmust use a virtual
service client, such as VMWare's Infrastructure Client Console, instead of a RemoteDesktop
Connection. Optional, IIS Web Server running on a separate server within the virtual environment.

Upgrade Installation Scenarios

You are upgrading an existing Stand Alone or Network installation. Your installation will upgrade if
you have a previous version installed.

You are upgrading theMIP programs and database in a virtual environment. Youmust use a virtual
service client, such as VMWare's Infrastructure Client Console, instead of a RemoteDesktop
Connection.
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For specific information regarding existing users, see "Existing User - Upgrading" (page 24), "Existing
User - Server Install" (page 28), and "Existing User - Workstation Install" (page 37).

Optional Alerts IIS Server Installation Scenarios

The Alerts installation will work with any of the above scenarios for Stand Alone or Network
installation. It is a common practice to have a separate IIS Web server as a part of your network so
that your SQL Server will not experience additional performance delays when processing
transactions or running reports.

If the IIS Web Server is installed on the same computer along with theMIP programs and database,
you could experience connection limitations and possible performance delays when processing
transactions and running reports.

If IIS Web Server is on amachine using aWindows 7, 8, 8.1, or 10 Operating System, the systemhas
a 10 concurrent connection limitation. This is a knownMicrosoft restriction when usingWindows 7,
8, 8.1, or 10 as the Alerts Server. It is recommended that you use a separate server on your network
as your IISWeb Server. Ideally, it could have an older server version Operating System running, such
asWindows Server 2008 R2. Note that having a local machinewithWindows 7, 8, 8.1, or 10 as a
MIP workstation will not cause any problems.

System Requirements
The latest system requirements are available at http://www.abila.com/solutions/abila-mip-fund-
accounting.You shouldmeet or exceed the AbilaMIP system requirements before you install the
application.

Important! Our SystemRequirements are changing; SQL Server 2008 is no longer supported
with this 2016 Spring release. Please verify that you are using an acceptable SQL Server version.

Before You Begin

For optimum results, perform the following tasks on the workstation and server before
running the installation program:

1. Verify that your current environment meets the new system requirements. You can view the
system requirements at http://www.abila.com/solutions/abila-mip-fund-accounting.



Before You Begin

Important! Our SystemRequirements are changing; SQL Server 2008 is no longer supported
with this 2016 Spring release. Please verify that you are using an acceptable SQL Server
version.

Important! Before installing or upgrading to the current software version, verify that you are a
user with Administrator rights on the SQL Server or have access to the SQL Server SystemAdmin
(SA) password. Upon upgrade, theMIP softwarewill be uninstalled. If you are not an
Administrator on the SQL Server nor have the SA password, you will not be able to install any
version of the software.

2. Shut down all applications that are currently running, and restart the computer.

3. AfterWindows has restarted, shut down any applications that have opened at start-up and turn off
the User Account Controls. Additionally, youmay need to disable some applications, such as Norton
AntiVirus©.

Press CTRL-ALT-DELETE to open theWindows Security form. Click the Task Manager button to
open theWindows Task Manager form. On the Applications tab, select each program listed in the
form, and click End Task.

Note: The above processes only shut down the applications for the purposes of the installation.
The next time the computer is rebooted, the programs and all Windows services are restored.

4. If theWindows Firewall is turned on, youmust configure exceptions in the firewall for SQL Server or
the client computer(s) will not be able to connect. For specific instructions on setting up the
exceptions, see article 5156 in the Knowledgebase at http://kb.abila.com/node/5156.

Note: Windows Firewall is turned on by default withWindows 2008 R2 Server and is set to block
remote connections.

5. Delete all files in the local TEMP directory, such as C:\Documents and Settings\<Current User>\Local
Settings\Temp. Since the computer has just rebooted and any unnecessary applications are closed,
there should be few files in the Temp directory. Nevertheless, delete any files or folders that remain
there.

6. If you are runningMIP on a laptop, set your hibernation settings to Never (Start>Settings>Control
Panel>PowerOptions>Power Schemes tab). Otherwise, when the computer times out, your seat will
become inactive.

7. Before you begin the server install:
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The user logged on to the servermachinemust be amember of the Local Administrators group
and a user with Administrator rights on the SQL Server or have access to the SQL Server System
Admin (SA) password.

Youmust haveMicrosoft .NET Framework 4.5.2 installed. You can verify your .NET version
using Control Panel>Programs and Features. For specific instructions on installing this version
of Microsoft.NET Framework, see article 7416 in the Knowledgebase at
http://kb.abila.com/node/7416.

Important! If the .NET framework is not installed, the AbilaMIP installation wizard cannot
continue. Youmust exit thewizard and restart it after you install the .NET framework version
4.5.2.

To install or upgradeMIP on a virtual environment, youmust use a virtual service client, such as
VMWare's Infrastructure Client Console, instead of a RemoteDesktop Connection.

For specific instructions for SQL Server 2012 Standard Edition configuration, see article 3156 in
the Knowledgebase at http://kb.abila.com/node/3156. It details how to check an existing
instance of SQL Server 2012 Standard Edition to ensure proper functionality before installing
MIP.

SQL Server 2014, SQL Server 2012, SQL Server 2008 R2, Windows 10, 8.1, 8 and 7
Users: Be sure to start the SQL Server Browser and consider setting the Start Mode to
Automatic to ensure that theworkstation can access theMIP systemdatabase.

Access the email sent to you by Abila which contains the link and download theMIP software to
the computer functioning as the AbilaMIP Server.

8. Before you begin theworkstation install, youmust ensure the following:

The user logged on to the servermachinemust be amember of the Local Administrators
group.

Each workstation has at the very least read-write access to the “ProgramData” folder--<local
drive letter:>\ProgramData. Also verify that each user that uses Aatrix® (for 1099s, W-2s, 990s,
1095s, etc.) has rights.

MIP cannot install successfully without these folders and rights.



Before You Begin

9. Before you begin the Alerts Setup install, verify that the following are installed:

Internet Information Server (IIS) 7.5 must be installed on theweb server. The AbilaMIP Alerts
installation will attempt to install IIS if it is not already installed.

10. Close any open windows.

After performing these steps, you are ready to run the Installation program.
TheGetting Started guide assists in setting up the chart of accounts once the system is successfully
installed, and Help is always available at the click of a button in the context-sensitive online help system.

Abila MIP
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Chapter 2: New User - Server Install

This chapter describes the installation process for a stand-alone, virtual, or network server. Youmust
select a database engine prior to installing the AbilaMIP Server. Once you have completed these steps,
follow the instructions in NewUser - Workstation Install to install theworkstation.

This chapter explains the following:

"Server Install Overview" (page 28)

"Local Server Configuration" (page 7)

"Directory StructureOverview" (page 29)

"SQL Server (Express Download)" (page 10)

"AbilaMIP Server Install" (page 11)

"Granting Access to theMIP Share Directory" (page 16)

Server Install Overview
The Server install is comprised of the following:

SQL Server Express- DownloadMicrosoft SQL Server 2014 Express with Advanced Services from
the SQL Server Express Installation link on the Setup tab of the AbilaMIP Install on the AbilaMIP
AutoRun.exe or use an already installed version of Microsoft SQL Server 2008 R2 Express Edition
with Advanced Services, SQL Server 2008 R2 (Full Version), SQL Server 2012 (Full Version), or
SQL Server 2014 (Full Version).

Abila MIP Server - The AbilaMIP Server installation creates theMIP Share directory. We
recommend accepting the default path when installing the server component.

The necessary files related to the AbilaMIP Server Install are copied to the SQL server. To download
theMicrosoft SQL Server 2014 Express Edition with Advanced Services from theMicrosoft website,
click the SQL Server Express Installation link that displays on the Setup tab of the AbilaMIP Install on
the AbilaMIP AutoRun.exe.

Important! Our SystemRequirements are changing; SQL Server 2008 is no longer supported
with this 2016 Spring release. Please verify that you are using an acceptable SQL Server version.

Abila MIP
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Important! Before installing the software, verify that you are a user with Administrator rights on
the SQL Server or have access to the SQL Server SystemAdmin (SA) password. Otherwise, you will
not be able to install the software.

Local Server Configuration
In order to successfully install and runMIP on a stand-alonemachine, verify that the File and Printer
Sharing Service is installed, the TCP/IP protocol is installed, and the Server Service is enabled. Then,
you need to complete the instructions in this chapter to ensure that the AbilaMIP Server is installed
correctly. Once you have completed these steps, follow the instructions in NewUser - Workstation
Install to install theworkstation.

Note: If you do not have a network adapter driver installed, you cannot continue theMIP install.
You need to install theMicrosoft Loopback Adapter first (follow the instructions below).

To Activate File and Printer Sharing Service:

1. Right-clickNetwork and then select Properties. TheNetwork and Sharing Center displays.

2. Under Sharing and Discovery, verify that File Sharing and Printer sharing are listed as On.

3. If Off displays, expand the down arrow and select the Turn on option.

To Enable the Server Service:

1. Go to Start>Settings>Control Panel>Administrative Tools>Services.

2. Double-click the Server Manager.

3. Expand Configuration, and click Services.

4. Make sure that the Startup type isAutomatic and the Server Status is Started. If those settings
are not in place, implement them, and then clickOK.

To Install TCP/IP:

1. Right-clickNetwork and then select Properties.

2. Click View Status for Local Area Connection and then click Properties.

3. If Internet Protocol Version 4 or 6 (TCP/IPv4/v6) is not selected in the list, check the box and click the
Install button. If it is listed, click OK and skip to step 6.

4. Select Protocol, and then click Add.



Directory Structure Overview

5. Select Internet Protocol (TCP/IP), and then clickOK.

6. Click Close to close the Local Area Connection Status window.

Note: If you are actually using TCP/IP to connect to your network, make sure that it is configured
properly.

Directory Structure Overview
The AbilaMIP Server executable (SETUP.EXE) creates theMIP Share directory. We recommend accepting
the default path when installing the server component.

Data Files and Directory Structure

When installing the AbilaMIP Server, the data files and workstation share files are stored on the
machine that is functioning as the server. Theworkstation installation stores theMIP system and
program files on each client machine.

After the server installation, the following directory structure exists on the drive and in the directory
that was specified during installation.

Abila MIP
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MIP Share Directory

Note: Do not Password Protect theMIP Share Directory.

This directory contains the following folders:

AATRIX contains the drafts and historical forms created by Aatrix, for each federal tax ID in the
Companies folder.

CONSOLIDATION FILES contains CONTEMP.TXT, which will be altered when consolidating data.

DATA contains a copy of theNPSSQLSYS.NPS and NTO.NPS files. These are the system and sample
database files that comewith the system.

DDEPOSIT contains ACH.TXT, which will be altered when using theDirect Deposit module.

EPAYAP contains ACHAP.TXT, which will be altered when using the Electronic Funds Transfer for A/P
module.

FORMATS contain the files needed to print custom forms in the system. This is where you should
store custom formats created by the Forms Designermodule.

GRANTADMIN contains scanned images of sample grant documentation for theGrant
Administrationmodule.

IMPORT includes sample DEF and data files that can be used with theData Import/Export module.

LOG contains ABILALOGACCT.LOG, ABILALOGADMIN.LOG, and ABILALOGPAYROLL.LOG files that
document when an error occurs related to the Alertsmodule, such as, failure to connect to the Alert
Server.

MIP DOCUMENTATION includes the product guides available in PDF format.

{ORGANIZATION DATABASE NAME} contains all folders for attachments. This folder is not
actually created until the attachments feature is activated in the system
(Organization>Attachments>Set Up Locations).

REPORT PDF FILES contains *.PDF files saved while using the Print to PDF feature.

SETUP contains the files necessary to run the AbilaMIP Workstation installation. Each of the client
machines will need to access this folder in order to install theWorkstation component. The
SETUP.EXE file launches the AbilaMIP Workstation installation.



SQL Server (Express Download)

SQLSCRIPTS contains SQL scripts necessary for the system to function properly.

SUPPORT contains support related folders.

SQL Server (Express Download)
Select one of the following that best describes your current setup, and then follow the instructions
below for installation:

SQL Server Express (can be downloaded by following a link) - Microsoft SQL Server 2014
Express Edition with Advanced Services can be downloaded from the SQL Server Express Installation
link on your AbilaMIP Version 2016.x Setup tab.

SQL 2014, SQL 2012, SQL 2008 R2, SQL Express (Already installed) - Either theMicrosoft SQL
Server or SQL Express has already been installed as your server using theMicrosoft website at
www.microsoft.com. Or SQL Server 2008 R2, 2012, or 2014 has already been installed as your
server.

The SQL installation creates the \Program Files\Microsoft SQL Server directory. By default, this directory
is located on the local drive in which your operating system is installed. Use the browser to change this
destination during the installation.

All users have the option to install their own instance of SQL Express or SQL Server. This gives you the
ability to administer it according to your practices.

SQL Server Express (Can be downloaded by following a link)

This section describes the installation process for theMicrosoft SQL Server 2014 Express Edition with
Advanced Services from the AbilaMIP Version 2016.x Setup Tab. Please carefully read each panel of the
wizard during installation.

Important! Before you begin, verify that Microsoft .NET Framework 4.5.2 or higher is installed
before you try to Install AbilaMIP Server. Go to Start>Settings>Control Panel>Programs and
Features.

1. Download theMIP software to the computer functioning as the AbilaMIP Server. To get the latest
download, see the Knowledgebase at www.abila.com/support.

Once complete, the system automatically launches autorun.exe and the AbilaMIP Setup window
displays.

Abila MIP
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2. Select SQL Server Express Installation and follow the steps to download SQL Server Express from
theMicrosoft website. Upon completion, be sure to install the SQL Server's latest service pack
updates before continuing the installation process.

Note: Click theHere link to open a browser to access instructions for installing the SQL Server
2014 - SP1 Express on the Knowledgebase.

Abila MIP Server Install
When installing the AbilaMIP Server, a directory is created by default—<Server Name>:\MIP SHARE.
The AbilaMIP Servermust be installed before proceeding to the "AbilaMIP Workstation Install" (page
19).

Note: To install or upgrade in a virtual environment, youmust use a virtual service client, such as
VMWare's Infrastructure Client Console, instead of a RemoteDesktop Connection.

Please carefully read each panel of thewizard during installation.

1. Be sure you are logged in as a user who has local administrator rights to perform the install. Also,
verify that you are a user with Administrator rights on the SQL Server or have access to the SQL
Server SystemAdmin (SA) password. (If you are not an Administrator on the SQL Server nor have
the SA password, you will not be able to install the software.)



Abila MIP Server Install

2. If you have not already done so, download theMIP software to the computer functioning as the
AbilaMIP Server.

The system automatically launches autorun.exe and the AbilaMIP Setup window displays.

3. After reviewing the provided documentation, select theBegin Installation Process option. The
systembegins extracting the setup.exe file.

4. The AbilaMIP Server InstallShield Wizard prepares to install. TheWelcome panel displays. Click
Next.

Abila MIP
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5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”
option to continuewith the Server Installation.

6. ClickNext. The systemdisplays the Product Registration panel. Enter the Serial Number and
Activation Code.

The activation code is case sensitive, so it must be entered exactly as it appears on the notification
included with the system. (Store the activation code in a safe place in case your system
needs to be reinstalled.)



Abila MIP Server Install

Activation
Codes

The activation code is determined by the system’s license. The systemuses the
activation code to determinewhichmodules you own, howmany additional
databases you have purchased, and howmany concurrent users you will have
available. Later, if you decide to add amodule or increase your users or databases,
you need to enter a new activation code. To enter a new license, with
Administrative user rights open the System>Activate License form. To add a
module to an existing database, use theOrganization>Add AModule form.

7. ClickNext. Accept the default MIP Share destination folder (recommended), or use the Change
button to navigate to a different location.

Abila MIP
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8. ClickNext. Select the database server that you are installing to by using the drop-down arrow, or
Browse to the database location.

Then, select how you want to connect to this server. If Server authentication is chosen, enter the
Login ID and Password.

9. ClickNext. You are now ready to Install AbilaMIP.

10. Click Install to begin, or use the Back button to make changes.

11. Proceed through theMIP Server setup. This processmay take several minutes.

12. When the installation is complete, the InstallShield Wizard Completed panel displays.



Granting Access to the MIP Share Directory

This is the final panel of the server installation. It verifies that the AbilaMIP Server installed
successfully.

Select the “Install AbilaMIP Workstation” check box, and then click Finish to continue through the
installation programby launching the AbilaMIP Workstation Installation wizard. For instructions,
proceed to NewUser - Workstation Install.

Alternatively, if you do not select the check box, you can install later from theMIP Share
directory. Formore information, see "Granting Access to theMIP Share Directory" (page 16).

Optional, install Alerts on your IIS Web Server. Formore information, see "Alerts IIS Install" (page
45)

13. Click Finish to complete the install.

14. If applicable, click the Exit button on the AbilaMIP Installation Startup form.

15. Navigate to theMIP Share directory on the Server and set it to sharewith Full control permissions to
Everyone.

Granting Access to the MIP Share Directory
TheMIP Share directory (which the Server installation created) contains the files necessary to install
MIP's program files at each workstation. First, theMIP Share directory must be shared so that the
workstations will have access to it.

1. Right-click theMIP Share directory at the server and select Share. . . If you do not see Shared, you
will need to log on as a user account that is amember of the Local Administrators or Power Users

Abila MIP
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group.

2. On the Sharing tab, click Advanced Sharing. And then select the Share this folder check box.

3. Click the Permissions button.

4. Add the desired users/groups.

Note: If you share to specific users/groups and not the “Everyone” group, you will need to add
the “System” account with full rights on the Security tab. If you give the “Everyone” group full
rights, then it is not necessary to add “System.”

5. Grant each user/group Full Control and clickOK. Aminimumof Change and Read permissions
are required. NTFS formatted servers will display a Security tab, in which case youmust grant NTFS
Permissions. You need to allow Systemwith Full Control. The Security tab will not be available if
the drive is formatted using FAT32.

6. ClickOK to close the Advanced Sharing window.

7. Click the Security tab.

8. Add the desired users/groups. Typically, the default NTFS permission is all you will need.
However, you can grant the users/groups Full Control access.

9. ClickOK to apply these settings.

10. Click Close to close theMIP Share Properties window.

Note: Youmust allow inheritable permissions.



Chapter 3: New User - Workstation Install

Before starting the Workstation installation, you must have already completed the "Abila
MIP Server Install" (page 11) and "Granting Access to the MIP Share Directory" (page 16), if
there is a network.

This chapter describes the installation process for the AbilaMIP Workstation. This installation provides
the program files needed to run the system. During the installation, you can choosewhich shortcut
and executable files to install for each system, such as Administration, Accounting, Payroll, or the entire
system. Please carefully read each panel of thewizard during installation.

The necessary files related to this installation are copied to theMIP Share directory of the server during
the AbilaMIP Server installation. There is only one executable (SETUP.EXE) for theworkstation install.

Note: The user logged on to theworkstationmachinemust be amember of the Local
Administrators group.

Ensuring Access to “All Users” Folder
Before you begin theworkstation install and you are using Aatrix®, youmust ensure that the
workstation has access to the “All Users” directory. The following steps should be completed for each
workstation running onWindows 7.

1. Click Start>Run.

2. Enter the <local drive letter:> in theOpen box.

3. ClickOK. The systemdisplays an explorewindow.

4. Open the Program Data folder.

5. Ensure that the “All Users” and <user name> folders are listed. Also verify that each user that uses
Aatrix® (for 1099s, W-2s, 990s, etc.) has “Full Control” rights (right-click on
folder>Properties>Security tab). AbilaMIP cannot install successfully without these folders and
rights. These steps should be completed for each workstation running onWindows 7, 8, 8.1, or 10.

Data Files and Directory Structure
When installing the AbilaMIP Workstation, the system and program files are stored on each computer.
After theworkstation installation, the following directory structure exists on the drive and in the

Abila MIP
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directory that was specified during installation.

MIP Directory

The AbilaMIP Workstation installation creates aMIP directory on the local disk partition with themost
space. This directory contains the following folders:

HELP contains all the files associated with the online help system.

PROGS contains the executable (*.EXE) files required to run the system. Specific *.DLL files are
included in the PROGS directory. Do NOT delete any of these files.

Abila MIP Workstation Install
This section describes theworkstation install. There are two ways to access this install:

If you selected the Install AbilaMIP Workstation check box at the end of the Server Install, the
system automatically launches theWelcome panel of the AbilaMIP Workstation install.

If you are installing theworkstation only, go to theworkstationmachine and log on as a user with
local administrator rights. Navigate to theMIP Share directory (\\MIP Share) on the Server, open the
Setup sub directory, and select Setup.exe.



Abila MIP Workstation Install

1. The AbilaMIP Workstation install Welcome panel displays.

2. ClickNext. Review the End User License Agreement and select the “I accept the terms in the license
agreement” option.

3. ClickNext. Accept the default MIP destination folder (recommended), or use the Change button to
navigate to a different location.

Abila MIP
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4. ClickNext. The Custom Setup panel displays, which allows you to select the systems you would
like to install. By default, the system installs the start menu shortcuts and program files for all
systems, even if they are not part of the license.

To prevent a system frombeing installed, ensure that the “X” (Entire featurewill be unavailable) is
selected. This designation prevents the installation of the program files and the start menu
shortcuts for that system. Youmay find this useful when you need to restrict a user from
launching a specific system.



Abila MIP Workstation Install

Note: If you do not install all systems now, but later decide you want to install the program files
or start menu shortcuts, you can do so using Start>Settings>Control Panel>Add or Remove
Programs. Select AbilaMIP Workstation and the Change button. The systemdisplays theWelcome
panel of the Install wizard. Click Next. Then, on the ProgramMaintenance panel, select theModify
option button, followed by theNext button.

5. ClickNext. The Install Wizard is ready to install the program.

6. Click Install to begin the installation, or click Back to make changes to your installation settings.

7. Proceed through the AbilaMIP Workstation setup. This processmay take several minutes. The
InstallShield Wizard Completed panel displays.

Abila MIP
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8. Click Continue to complete theWorkstation Install.

9. Additional installs launch after you click Continue to complete theWorkstation Install. Allow any
additional installs to complete, and then clickOK on the “Your install completed successfully”
windowmessage.

10. This is the final window of theworkstation installation. It verifies that the AbilaMIP Workstation
installed successfully.

Optional, install Alerts on your IIS Web Server. Formore information, see "Alerts IIS Install"
(page 45)

If applicable, click the Exit button on the AbilaMIP Installation Setup form.

At the end of theWorkstation install, reboot your computer only if prompted to do so.

Note: Remember, a workstation installationmust be performed on each workstation that needs to
run AbilaMIP.



Chapter 4: Existing User - Upgrading

This chapter provides information that only existing usersmight need. It explains:

"Upgrading from a Previous Version" (page 24)

"Changing Your Database Engine" (page 25)

"Updating Your Organization Database to Version 2016.2" (page 25)

"Activating Your License" (page 26)

"Adding aModule to an Organization" (page 26)

"Setting Up Security" (page 27)

Upgrading from a Previous Version
You can only upgrade your program files to version 2016.2 from versions 2016.1.1, 2016.1, and
2015.2. If you are not currently running one of these versions, youmust upgrade to one of them
before you can upgrade the application files to 2016.2.

Important! Our SystemRequirements are changing; SQL Server 2008 is no longer supported
with this 2016 Spring release. Please verify that you are using an acceptable SQL Server version.

Important! Before upgrading to the current software version, verify that you are a user with
Administrator rights on the SQL Server or have access to the SQL Server SystemAdmin (SA)
password. Upon upgrade, theMIP softwarewill be uninstalled. If you are not an Administrator on
the SQL Server nor have the SA password, you will not be able to install any version of the software.

1. Follow the instructions in Existing User - Server Install to upgrade the organizational database on a
server from a previous version.

2. Once you have installed the AbilaMIP Server, you will need to install theworkstation.

Open the setup.exe from the \\MIP Share\Setup directory on your server, to launch the "Abila
MIP Workstation Install" (page 38).

If the AbilaMIP Workstation component is already installed on the server or you wish to install
theWorkstation on the server for the first time, you will need to open the application on the
server to complete the upgrade process before proceeding to the next step.
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3. Follow the instructions in Existing User - Workstation Install, to upgrade each user’s workstation.

4. Finally, follow the instructions to complete the Alerts installation on your IISWeb Server.

Changing Your Database Engine
If you are upgrading andmoving your database to a different instance of SQL Express or SQL Server,
back up your system and organization databases, and then uninstall MIP and your current instance of
SQL.

After you complete the installation process, restore your systemdatabase, NPSSQLSYS, along with
your organization database. For specific instructions on uninstalling, see "Uninstalling AbilaMIP" (page
53) and see "Supplemental Maintenance" (page 56) for instructions on backing up and restoring a
database.

For specific instructions onmoving the AbilaMIP Server to a new server/computer, see article 876 in
the Knowledgebase at http://kb.abila.com/node/876.

Updating Your Organization Database to Version 2016.2
You can only update your organization database after the server and workstation have been
upgraded to version 2016.2. To do so:

1. Log on to any system (Start>Programs>Abila>MIP>MIP Fund Accounting), and select an
Organization.

2. The systemdisplays amessage stating that the organization databasemust be updated to the
current version.

Select Yes, to begin the backup process to back up your organization database and then
upgrade it. This is strongly recommended.

Select No, if you have a current backup of the database and want to begin the update process
immediately.

3. A utility program runs. Click Finish.

4. When complete, amessage displays informing you that your database has been updated
successfully.

5. ClickOK.
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Activating Your License
When you initially purchase the system, an activation code that activates any and all modules that have
been purchased is included with the software. You are prompted to enter that code during installation,
and do not need to enter it any other time. However, if you are currently using the system and decide
to add amodule (or add users or databases), a new activation codewill be sent to you.

Enter the new code in the system in order to use the new features:

1. Open the System>Activate License form.

2. On theOwned tab (or Evaluation tab if evaluating a newmodule), enter the new activation code.
Note that the activation code is case sensitive, so it must be entered exactly as it appears on the
notification.

3. ClickOK, and then the new features are registered in the system.

4. Exit the system (File>Exit), and then reopen it.

Note: If you were evaluating or adding the Schedulermodule, and you did not include the program
files and start menu shortcut, you can do so now. Click Start>Settings>Control Panel>Add or Remove
Programs. Select AbilaMIP Workstation and the Change button. The systemdisplays theWelcome
panel of the Install wizard. Click Next. Then, on the ProgramMaintenance panel, select theModify
option button, followed by theNext button.

Important!
With version 2015.2, the Accounting, Administration, Payroll, and Electronic Requisition systems have
beenmerged into MIP Fund Accounting. By default, the system installs theMIP Fund Accounting
start menu shortcut and program files for all systems, even if they are not part of the license. Be sure,
to set up security rights for all users and groups in the active organization, otherwise, they will have
access to every menu in the system.

Adding a Module to an Organization
Amodule can be added to the current organization, but first ensure that there are no users currently
logged on to the system.

Note: The activation codemust be changed (MIP Fund Accounting>System>Activate License) to
include Scheduler, Electronic Requisitions, and Payroll modules before thesemodules can be added.
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To add a module:

1. Open theMIP Fund Accounting>System>Current Activity form to ensure that no one
(except yourself) is currently using the organization being updated.

2. Open the organization (File>Open Organization) in which to add themodule.

3. Open theOrganization>Add a Module wizard. On the first panel, select themodule to add by
selecting the appropriate check box.

4. Follow the instructions on the screen and continue through thewizard.

5. Click Finish, and then the system adds the designatedmodule to the current organization. This
processmay take several minutes.

6. To add amodule to another organization, repeat this process.

Note: Formore information about the Add aModulewizard, see the online help or the
Administration guide.

Setting Up Security
User security needs to be set up for each newmodule. To do so:

1. Open the Security>Set Up Organization Menus form to grant rights to users. This includes
granting rights to newmenu selections that are part of the newmodule.

2. Remember, this processmust be repeated for each separate organization in which themodule
was added and requires exclusive access to the systemdatabase.

Note: Formore information about the Set Up OrganizationMenus form, see the online help or the
Administration guide.
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This chapter describes the installation process for a stand-alone or network server. Prior to upgrading
the AbilaMIP Server Install, youmust close all workstations. Once you have completed the steps in this
chapter, follow the instructions in Existing User - Workstation Install to install theworkstation.

This chapter explains the following:

"Server Install Overview" (page 28)

"Directory StructureOverview" (page 29)

"SQL Server Install " (page 30)

"AbilaMIP Server Install" (page 32)

Server Install Overview
The Server install is comprised of the following:

SQL Server Express- DownloadMicrosoft SQL Server 2014 Express with Advanced Services from
the SQL Server Express Installation link on the Setup tab of the AbilaMIP Install on the AbilaMIP
AutoRun.exe or use an already installed version of Microsoft SQL Server 2008 R2 Express Edition
with Advanced Services, SQL Server 2008 R2 (Full Version), SQL Server 2012 (Full Version), or
SQL Server 2014 (Full Version).

Abila MIP Server - The AbilaMIP Server installation creates theMIP Share directory. We
recommend accepting the default path when installing the server component.

The necessary files related to the AbilaMIP Server Install are copied to the SQL server. To download
theMicrosoft SQL Server 2014 Express Edition with Advanced Services from theMicrosoft website,
click the SQL Server Express Installation link that displays on the Setup tab of the AbilaMIP Install on
the AbilaMIP AutoRun.exe.

Important! Our SystemRequirements are changing; SQL Server 2008 is no longer supported
with this 2016 Spring release. Please verify that you are using an acceptable SQL Server version.

Important! Before installing the software, verify that you are a user with Administrator rights on
the SQL Server or have access to the SQL Server SystemAdmin (SA) password. Otherwise, you will
not be able to install the software.
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Directory Structure Overview
The AbilaMIP Server executable (SETUP.EXE) creates theMIP Share directory. We recommend
accepting the default path when installing the server component.

Data Files and Directory Structure

When installing the AbilaMIP Server, the data files and workstation share files are stored on the
machine that is functioning as the server. Theworkstation installation stores theMIP system and
program files on each client machine.

After the server installation, the following directory structure exists on the drive and in the directory
that was specified during installation.

MIP Share Directory

Note: Do not Password Protect theMIP Share Directory.

This directory contains the following folders:

AATRIX contains the drafts and historical forms created by Aatrix, for each federal tax ID in the
Companies folder.

CONSOLIDATION FILES contains CONTEMP.TXT, which will be altered when consolidating data.



SQL Server Install

DATA contains a copy of theNPSSQLSYS.NPS and NTO.NPS files. These are the system and sample
database files that comewith the system.

DDEPOSIT contains ACH.TXT, which will be altered when using theDirect Deposit module.

EPAYAP contains ACHAP.TXT, which will be altered when using the Electronic Funds Transfer for A/P
module.

FORMATS contain the files needed to print custom forms in the system. This is where you should
store custom formats created by the Forms Designermodule.

GRANTADMIN contains scanned images of sample grant documentation for theGrant
Administrationmodule.

IMPORT includes sample DEF and data files that can be used with theData Import/Export module.

LOG contains ABILALOGACCT.LOG, ABILALOGADMIN.LOG, and ABILALOGPAYROLL.LOG files that
document when an error occurs related to the Alertsmodule, such as, failure to connect to the Alert
Server.

MIP DOCUMENTATION includes the product guides available in PDF format.

{ORGANIZATION DATABASE NAME} contains all folders for attachments. This folder is not actually
created until the attachments feature is activated in the system (Organization>Attachments>Set Up
Locations).

REPORT PDF FILES contains *.PDF files saved while using the Print to PDF feature.

SETUP contains the files necessary to run the AbilaMIP Workstation installation. Each of the client
machines will need to access this folder in order to install theWorkstation component. The
SETUP.EXE file launches the AbilaMIP Workstation installation.

SQLSCRIPTS contains SQL scripts necessary for the system to function properly.

SUPPORT contains support related folders.

SQL Server Install

Important! Our SystemRequirements are changing; SQL Server 2008 is no longer supported with
this 2016 Spring release. Please verify that you are using an acceptable SQL Server version.

Select one of the following that best describes your current setup, and then follow the instructions
below for installation:
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SQL Server Express (can be downloaded by following a link on the AutoRun.exe) -
Microsoft SQL Server 2014 Express Edition with Advanced Services can be downloaded from the
SQL Server Express Installation link on the Abila AutoRun.exe.

SQL 2014, SQL 2012, SQL 2008 R2, SQL Express (Already installed) - Either theMicrosoft
SQL Server or SQL Express have already been installed as your server using theMicrosoft website at
www.microsoft.com. Or, SQL Server 2008 R2, 2012, 2014 has already been installed as your server.

The SQL installation creates the \Program Files\Microsoft SQL Server directory. By default, this
directory is located on the local drive in which your operating system is installed. Use the browser to
change this destination during the installation.

Important! Before installing the software, verify that you are a user with Administrator rights on
the SQL Server or have access to the SQL Server SystemAdmin (SA) password. Otherwise, you will
not be able to install the software.

All users have the option to install their own instance of SQL Express or SQL Server. This gives you the
ability to administer it according to your practices.

SQL Server (Express Downloaded)

This section describes the download process for theMicrosoft SQL Server 2014 Express Edition with
Advanced Services from the Abila AutoRun.exe. Please carefully read each panel of thewizard during
installation.

Important! Before you begin, verify that Microsoft .NET Framework 4.5.2 or higher is installed
before you try to Install MIP Server. Go to Start>Settings>Control Panel> Programs and
Features.

1. On the computer functioning as theMIP Server, log on as a user with local administrator rights.

Note: With the release of version 2016.2, the Abila Auto Update programwas discontinued and
will be uninstalled during thisMIP installation process.

2. Download and extract the latest MIP software updates to the computer functioning as the Abila
MIP Server. To get the latest download, see the Knowledgebase at www.abila.com/support.
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Important! Before upgrading to the current software version, verify that you are a user with
Administrator rights on the SQL Server or have access to the SQL Server SystemAdmin (SA)
password. Upon upgrade, theMIP softwarewill be uninstalled. If you are not an Administrator on
the SQL Server nor have the SA password, you will not be able to install any version of the
software.

Once the download is complete, the system automatically launches autorun.exe and theMIP Setup
window displays.

3. Select SQL Server Express Installation and follow the steps to download SQL Server Express from
theMicrosoft website. Upon completion, be sure to install the SQL Server's latest service pack
updates before continuing the installation process.

Note: Click theHere link to open a browser to access instructions for installing the SQL Server
2014 - SP1 Express on the Knowledgebase.

Abila MIP Server Install
This section describes the install process by continuing to use your existing database server, however,
the softwarewill be uninstalled and reinstalled.

TheMIP Servermust be upgraded before proceeding to the "Existing User - Workstation Install" (page
37). It is very important to perform a backup of your database before performing the upgrade.
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Please carefully read each panel of thewizard during installation.

Note: To install or upgrade in a virtual environment, youmust use a virtual service client, such as
VMWare's Infrastructure Client Console, instead of a RemoteDesktop Connection.

1. On the computer functioning as theMIP Server and log on as a user with local administrator
rights.

Important! Before upgrading to the current software version, verify that you are a user with
Administrator rights on the SQL Server or have access to the SQL Server SystemAdmin (SA)
password. Upon upgrade, theMIP softwarewill be uninstalled. If you are not an Administrator
on the SQL Server nor have the SA password, you will not be able to install any version of the
software.

2. If you have not already done so, download and extract the latest AbilaMIP software to the
computer functioning as theMIP Server. To get the latest download, see the Knowledgebase at
www.abila.com/support.

3. Once complete, the system automatically launches autorun.exe and the AbilaMIP Setup window
displays. After reviewing the provided documentation, select theBegin Installation Process
option.

The systembegins extracting the setup.exe file.

4. The AbilaMIP Server InstallShield Wizard prepares to install. TheWelcome panel displays. Click
Next.
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5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”
option to continuewith the Server Installation.

6. ClickNext. You are now ready to Install AbilaMIP.

7. Click Install to begin, or use the Back button to make changes.
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8. The systembegins upgrading the AbilaMIP Server software. This processmay take several
minutes.

9. When the upgrade is complete, the InstallShield Wizard Completed panel displays.

This is the final panel of the server installation. It verifies that the AbilaMIP Server installed
successfully.

Select the “Install AbilaMIP Workstation” check box, and then click Finish to continue through
the installation programby launching the AbilaMIP Workstation Installation wizard. For
instructions, proceed to "Existing User - Workstation Install" (page 37).
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Alternatively, if you do not select the check box, you can install later from theMIP Share
directory. Formore information, see "Granting Access to theMIP Share Directory" (page 16).

Optional, install Alerts on your IIS Web Server. Formore information, see "Alerts IIS Install" (page
45)

10. Click Finish to complete the install.

11. If applicable, click the Exit button on the AbilaMIP Installation Startup form.

12. Navigate to theMIP Share directory on the Server and set it to sharewith Full control permissions to
Everyone.

Note: Reboot your computer only if prompted to do so.
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Before starting the Workstation Installation, you must have already completed the Abila
MIP Server Install and Granting Access to the MIP Share Directory, if there is a network.

This chapter describes the installation process for the AbilaMIP Workstation. This installation provides
the program files needed to run the system. During the installation, theMIP Fund Accounting shortcut
and executable files install and you can choose for each system, such as Scheduler or the entire
system. Please carefully read each panel of thewizard during installation.

Important!
With version 2015.2, the Accounting, Administration, Payroll, and Electronic Requisition systems
have beenmerged into MIP Fund Accounting. By default, the system installs theMIP Fund
Accounting start menu shortcut and program files for all systems, even if they are not part of the
license. Be sure, to set up security rights for all users and groups in the active organization,
otherwise, they will have access to every menu in the system.

The necessary files related to this installation are copied to theMIP Share directory of the server during
the AbilaMIP Server installation. There is only one executable (SETUP.EXE) for theworkstation install.

Note: The user logged on to theworkstationmachinemust be amember of the Local
Administrators group.

Ensuring Access to “All Users” Folder
Before you begin theworkstation install and you are using Aatrix®, youmust ensure that the
workstation has access to the “All Users” directory. The following steps should be completed for each
workstation running onWindows 7.

1. Click Start>Run.

2. Enter the <local drive letter:> in theOpen box.

3. ClickOK. The systemdisplays an explorewindow.

4. Open the Program Data folder.

5. Ensure that the “All Users” and <user name> folders are listed. Also verify that each user that uses
Aatrix® (for 1099s, W-2s, 990s, etc.) has “Full Control” rights (right-click on
folder>Properties>Security tab). AbilaMIP cannot install successfully without these folders and
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rights. These steps should be completed for each workstation running onWindows 7, 8, 8.1, or
10.

Data Files and Directory Structure
When installing the AbilaMIP Workstation, the system and program files are stored on each
computer. After theworkstation installation, the following directory structure exists on the drive and
in the directory that was specified during installation.

MIP Directory

The AbilaMIP Workstation installation creates aMIP directory on the local disk partition with themost
space. This directory contains the following folders:

HELP contains all the files associated with the online help system.

PROGS contains the executable (*.EXE) files required to run the system. Specific *.DLL files are
included in the PROGS directory. Do NOT delete any of these files.

Abila MIP Workstation Install
The AbilaMIP Servermust be upgraded prior to upgrading the AbilaMIP Workstation.

If you selected the Install AbilaMIP Workstation check box at the end of the Server Install, the system
automatically launches theWelcome panel of the AbilaMIP Workstation install.
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When the existing data engine configuration is kept on each workstation, select
Start>Programs>Abila>MIP>{any application}. The systemdisplays amessage indicating a new
version is required; select Yes to automatically launch the AbilaMIP Workstation Installation.

If the auto launch fails, due to the data engine configuration changing orWindowsOS users with User
Account Control turned on, follow the steps below to launch the AbilaMIP Workstation Install.

Note: Youmust access \MIP SHARE using a UNC Path, not amapped drive. Mapped drives are okay
as long as they are consistent and persistent across all workstations, such as everyone having a
G:\drivemapped to MIP Share.

Click Start>Run.

Enter the <\\server name> in theOpen box.

ClickOK. The systemdisplays an explorewindowwith all the shared folders listed.

Open theMIP Share directory on the server.

Open the Setup folder and run SETUP.EXE.

Important! Windows OS Users - If the User Account Control is turned on, amessage displays that “A
programneeds your permission to continue,” click Continue to proceed.

The system automatically launches theWelcome panel of the AbilaMIP Workstation install, if you
selected the Install AbilaMIP Workstation check box at the end of the Server Install or opened an
application after the Server was updated.

If you are installing theworkstation only, go to theworkstationmachine and log on as a user with local
administrator rights. Navigate to theMIP Share directory (\\MIP Share) on the Server, open the Setup
sub directory, and select Setup.exe.
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1. The AbilaMIP Workstation InstallShield Welcome panel displays.

2. ClickNext. Review the End User License Agreement and select the “I accept the terms in the
license agreement” option.

3. ClickNext. Accept the default MIP destination folder (recommended), or use the Change button
to navigate to a different location.



Abila MIP Workstation Install

4. ClickNext. The Custom Setup panel displays, which allows you to select the systems you would like
to install.

Important!
With version 2015.2, the Accounting, Administration, Payroll, and Electronic Requisition systems
have beenmerged into MIP Fund Accounting. By default, the system installs theMIP Fund
Accounting start menu shortcut and program files for all systems, even if they are not part of the
license. Be sure, to set up security rights for all users and groups in the active organization,
otherwise, they will have access to every menu in the system.

The Scheduler systemwas not merged because it is an application used to monitor scheduler
activities. To prevent the Scheduler system frombeing installed, ensure that the “X” (Entire feature
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will be unavailable) is selected. This designation prevents the installation of the program files and
the start menu shortcut for that system. Youmay find this useful when you need to restrict a user
from launching the Scheduler system.

Note: If you do not install all systems now, but later decide you want to install the Scheduler
program files or start menu shortcut, you can do so using Start>Settings>Control Panel>Add or
Remove Programs. Select AbilaMIP Workstation and the Change button. The systemdisplays
theWelcome panel of the Install wizard. Click Next. Then, on the ProgramMaintenance panel,
select theModify option button, followed by theNext button.

5. ClickNext. The Install Wizard is ready to install the program.

6. Click Install to begin the installation, or click Back to make changes to your installation settings.

7. The systembegins upgrading the AbilaMIP Workstation software. This processmay take several
minutes. The InstallShield Wizard Completed panel displays.
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8. Click Continue to complete theWorkstation upgrade.

9. Additional installs launch after you click Continue to complete theWorkstation upgrade. Allow any
additional installs to complete, and then clickOK on the “Your install completed successfully” form.

10. This is the final window of theworkstation installation. It verifies that the AbilaMIP Workstation
installed successfully. If applicable, click the Exit button on the AbilaMIP Installation Setup form.

Note: At the end of theWorkstation install, reboot your computer only if prompted to do so.

11. If the AbilaMIP Workstation component is already installed on the server or you have installed the
Workstation on the server for the first time, you will need to open the application on the server to
complete the upgrade process, which allows the system to automatically update this component.

Note: If the AbilaMIP Workstation component is not installed on the server, a workstation
installationmust be performed on each workstation that needs to run AbilaMIP.

12. Open theOrganization>Add a Module wizard. Run through this wizard to add any newmodules.

13. Open the Security>Set Up Organization Menus form to grant rights to newmenu selections
that are part of any newmodules that were added.
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Important!
With version 2015.2, the Accounting, Administration, Payroll, and Electronic Requisition systems
have beenmerged into MIP Fund Accounting. By default, the system installs theMIP Fund
Accounting start menu shortcut and program files for all systems, even if they are not part of
the license. Be sure, to set up security rights for all users and groups in the active organization,
otherwise, they will have access to every menu in the system.

14. Optional, install Alerts on your IIS Web Server. Formore information, see "Alerts IIS Install" (page
45)



Chapter 7: Alerts IIS Install

This chapter includes specific instructions on how to install the AbilaMIP Alerts on aweb server.

Download Abila MIP
1. To download AbilaMIP, click the link in the email received from your Abila sales representative to

open the AbilaMIP download page. To install Version 2016.x, select the appropriate download link.

2. The system automatically runs SETUP.EXE. The AbilaMIP installationmenu displays the Setup tab.

3. Review the following documents: Quick Start, Installation Guide, and System Requirements. You can
print these documents or review themonline.

Begin Installation Process

Before you begin, you must ensure the following:

The user logged on the servermachinemust be amember of the Local Administrators group, as well
as an Administrator on the database server.
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Verify that Microsoft .NET Framework of 4.5.2 Full or higher and Internet Information Services (IIS)
7.5 or higher are installed.

Verify that you have AbilaMIP installed and have accessed the system at least once.

Confirm the location and access to the AbilaMIP database server.

Caution! If IIS Web Server is on amachine using aWindows 7, 8, 8.1, or 10 Operating System, the
systemhas a 10 concurrent connection limitation. This is a knownMicrosoft restriction when using
Windows 7 or 8 as the Alerts Server. It is recommended that you use a separate server on your
network as your IISWeb Server. Ideally, it could have an older server version operating system
running, such asWindows Server 2008 R2. Note that, having a local machinewithWindows 7 or 8,
as aMIP workstation, will not cause any problems.

Important! If the IIS Web Server is installed on the same computer along with theMIP programs
and database, you could experience connection limitations and possible performance delays when
processing transactions and running reports.
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Abila MIP Alerts Server Install

Complete the following steps to install Abila MIP Alerts on the web server.

1. After reviewing the provided documentation, select the Setup Alerts tab.

2. Select theBegin Alerts Installation Process option. The systembegins extracting the setup.exe
file.

3. The system verifies theMicrosoft .NET Framework and Internet Information Services (IIS) versions.
If your web server does not have the latest versions, the AbilaMIP Alerts installation wizard cannot
continue. Youmust exit thewizard and restart it after you install the .NET Framework version 4.5.2
and/or IIS version 7.5.

Note: If IIS or .NET is updated to a newer version, youmight be prompted to restart your server.

Important! If the User Account Control is not turned off, click Yes to allow the changes to the
computer.

4. The AbilaMIP Alerts IIS InstallShield Wizard prepares to install. TheWelcome panel displays. Click
Next.
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5. The End User License Agreement displays. Select the “I accept the terms in the license agreement”
option to continuewith the Alerts IIS Installation.

6. ClickNext. Select the database server that you are installing to by using the drop-down arrow, or
Browse to the database location.

Then, select how you want to connect to this server. If Server authentication is chose, enter the
Login ID and Password.
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7. ClickNext. You are now ready to Install Abila Alerts IIS.

8. Click Install to begin, or use the Back button to make changes.

9. During the installation process, a progress bar displays, as well as several windowswill open and
close. This processmay take several minutes to complete.

10. When the installation is complete, the InstallShield Wizard Completed panel displays.
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11. Click Finish to complete the install.

12. If applicable, click the Exit button on the AbilaMIP Installation Startup form.

Before you begin creating Real-time Alert notices, you will need to make sure everything is setup in
Administration. Formore information about setting up Alerts, seeHow Do I Set Up Alerts? and for
steps to create themany different Alert notifications, seeHow Do I Create an Alert? These are
available as checklists for Administration in the AbilaMIP system's Online Help (Help>Checklists).

Setting Up Alerts
Complete these steps in the following order to be begin creating Real-time Alert notices:

1. Complete theOptional Alerts Install:

On the server functioning as your network's web server,

The user logged on the servermachinemust be amember of the Local Administrators
group, as well as an Administrator on the database server.

Verify that Microsoft .NET Framework of 4.5.2 Full or higher and Internet Information
Services (IIS) 7.5 or higher are installed.

Confirm the location and access to the AbilaMIP database server.

Using Abila Auto Update download and extract the AbilaMIP installation, select the Setup
Alerts tab, and complete the Alerts Installation process.
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Caution! If IIS Web Server is on amachine using aWindows 7, 8, 8.1, or 10 Operating System, the
systemhas a 10 concurrent connection limitation. This is a knownMicrosoft restriction when
usingWindows 7 or 8 as the Alerts Server. It is recommended that you use a separate server on
your network as your IISWeb Server. Ideally, it could have an older server version operating
system running, such asWindows Server 2008 R2. Note that, having a local machinewith
Windows 7 or 8, as aMIP workstation, will not cause any problems.

Important! If the IIS Web Server is installed on the same computer along with theMIP programs
and database, you could experience connection limitations and possible performance delays
when processing transactions and running reports.

2. Review the Setting Up YourOrganization checklist to ensure that the organization is set up properly.

3. As a user with Administration rights, perform the following steps:

a. Ensure all of your users have email addresses and have been added to the organization using the
Security>Maintain Users form.

b. Ensure that the SMTP Email is set up and configured using the following steps:

i. Enter the Set Up SMTP Connection information using theOrganization>Organization
Information>SMTP Email tab. (To view examples of how to set up your SMTP connection, see
Configuring SMTP.)

ii. Enter the From and To email addresses to test your connection is set up correctly.

iii. Click the Send Test Email button.

iv. Click Save.

c. Create an Alert and assign users using theOrganization>Set Up Alerts form. (To view examples
of how to create an alert, see HowDo I Create an Alert? The Administration checklist is available
in the AbilaMIP system's Online Help (Help>Checklists)

d. UseOptions>SystemPreferences to enter a default From email address for Alerts, However, if
the Use CustomCredentials check box is selected on theOrganization>Organization
Information>SMTP Email tab; the User email address entered theremust be the default From
email address.
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Note: SystemUsers have the ability to turn off the Real-time In-product notifications, by
clearing theConnect to the Alert Server check box on theOptions>User Preferences form. If
not selected, the alerts will continue to collect in theMessage Center and Real-time Email Alert
Notices will be sent, but the number count on theMessage Center will not reflect accurately.



Chapter 8: Uninstalling Abila MIP

This chapter describes how to uninstall the AbilaMIP system.

Uninstalling Steps
The following componentsmust be uninstalled in this order:

1. AbilaMIP Workstation

2. AbilaMIP Server

Before uninstalling, make a backup of the organization database; see Supplemental Maintenance for
more information. Uninstall only removes the files that the installation process copied to
your computer.

Data Import/Export,
Direct Deposit, EFT
for A/P, and Forms
Designer Users

When installing, the system copies files to the \MIP SHARE\IMPORT,
DDEPOSIT, EPAYAP, and FORMATS directories. During the uninstall process
these files are removed. If changes have beenmade to these files, either
change the names of the files ormove them to another directory.

To Remove the Abila MIP Workstation:

1. Go to Start>Settings>Control Panel.

2. Click Programs and Features.

3. Select Abila MIP Workstation, and then click Uninstall.

–OR–

If you are uninstalling a AbilaMIP Workstation on a computer, which acts as a client only (it is not on
the AbilaMIP Server), run theUninstall on the Server through aUNC path (<server name>\MIP
Share\Setup\Uninstall).

To Remove the Abila MIP Server:

1. Go to Start>Settings>Control Panel.

2. Click Programs and Features.

3. Select Abila MIP Server, and then click Uninstall.
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To Remove the Abila Auto Update plug in for MIP:

1. Go to Start>Settings>Control Panel.

2. Click Programs and Features.

3. Select Abila.AAU.MIP, and then click Uninstall.

To Remove the Abila MIP System including all Third Party Applications:

1. Use theUnistall shortcut on <local drive letter:>\MIP Share\Setup folder.



Chapter 9: Help Documentation

This chapter describes how to access theMIP help documentation.

Accessing Documentation
The Installation and Getting Started guides are provided with your new system. Other guides and help
files are automatically installed as part of the Server Installation process. Therefore, documentation is
now easily accessible to all workstations through the \MIP Share\MIP Documentation\PDFs directory
and the \Program Files\MIP\Help directory.

Some product guides are available in PDF format. You can access these PDF files using
Help>Product Guides or click Help and Support>Resource Center>Product Guides on the
Navigation pane. These PDF files can be viewed and printed using a program, such as the Adobe®
Reader®. To install Adobe Reader, you can download it for free fromhttp://www.adobe.com/.

The online help's “context-sensitive” feature is an easy way to get help when you need it most.
Context-sensitivemeans that the system knowswhere you areworking within the system so when
you need help, you can press the F1 key or click theHelp button. There is a wealth of information
available that you can use daily to help you in your work. By experimenting with online help, you
learn to use the systemquickly, effectively, and efficiently.
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The following information is useful for backing up, restoring, and compressing your organizational
database.

Backing Up Organization Database
You can back up and restore all organization databases and the systemdatabase (NPSSQLSYS) for the
current version. When running a backup, the system creates an uncompressed copy of the database.

You can back up any databasewhile users are in the system. However, to restore a database, all users
must exit the system.

1. As the Administrator, log on toMIP Fund Accounting (Start>Programs>Abila>MIP Fund
Accounting). You do not have to select an Organization.

2. Open the File>Backup form.

3. Select the database you want to back up from theDatabase to Backup drop-down list.

4. Accept the default name (the database name, date, and time) or enter another name in the
Backup to File box.

5. If needed, click theBrowse button and select the backup directory.

6. Click the Start button. The systembacks up the database.

7. A dialog box will indicate the location of the backup when the process is finished.

Restoring Organization Database
1. As the Administrator, log on toMIP Fund Accounting (Start>Programs>Abila>MIP Fund

Accounting). You do not have to select an Organization.

2. Open the File>Restoreform.

3. Select the database to restore from the drop-down list. If this is the first time a database has been
restored, its name is not available in the drop-down list; youmust enter a namehere.

4. Enter the name in theRestore to File box.
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5. Click theBrowse button to locate the file.

6. Click the Start button.

The path to theMDF file that you backed up is stored in the backup file. When attempting to restore
the backup file, the system looks for the same path.

Compressing Organization Database
Before starting the compress process, all usersmust exit the system.

1. As the Administrator, log on toMIP Fund Accounting (Start>Programs>Abila>MIP), but do
not select an Organization.

2. Open the File>Compress form.

3. Select the database to compress from the drop-down list.

4. Click the Start button.

Note: Compressing large databases can take quite some time. If the actual database file has spaces
in the name, the compression programwill not work.


